quarta-feira, 5 de outubro de 2016

Excel : Formatação condicional com datas

Muitas pessoas perguntam nos cursos de Excel, como criar uma planilha com formatação condicional com datas, ou seja, quando uma data está se aproximando, o Excel deverá formatar a planilha com uma cor diferente, que servirá como um alerta para um pagamento, compromisso ou até receber bonificações ou comissões.

Como funciona?

Você faz uma planilha com os gastos do mês, por exemplo, aqui uma bem básica...

Selecione o intervalo das datas...Posicione o cursor na célula B2, clique e arraste até B11.


Depois disso, na faixa de Opções do Excel, clique em Formatação Condicional e vamos criar uma Nova Regra

Depois clique em "Usar uma fórmula para determinar quais células devem ser formatadas"


Na caixa "Edite valores em que esta fórmula é verdadeira" e digite a fórmula que compara a data da planilha com a data de hoje.

Essa fórmula diz o seguinte para o Excel:
=SE(B2>Hoje();verdadeiro)

Se a célula B2 tiver uma data maior que a data de hoje....

Clique no botão Formatar
e
vamos para a Formatação Condicional....

Na Guia Preenchimento, escolha uma cor para o fundo da célula, 
Aqui eu escolhi um verde para dizer que a data de pagamento ainda não chegou...

Clicando em OK, vemos que as datas que ainda não chegaram, ficaram formatadas em verde ..

Vamos novamente para a Formatação Condicional e depois clique em Gerenciar Regras 

Adicione uma Nova Regra e 
depois clique em "Usar uma fórmula para determinar quais células devem ser formatadas"

Na caixa "Edite valores em que esta fórmula é verdadeira" e digite a fórmula que compara a data da planilha com a data de hoje.

Essa fórmula diz o seguinte para o Excel:
=SE(B2=Hoje();verdadeiro)

Se a célula B2 tiver uma data igual a data de hoje....

Clique no botão Formatar
e
vamos novamente para a Formatação Condicional....

Na Guia Preenchimento, escolha uma cor para o fundo da célula, 
Dessa vez eu escolhi a cor laranja para dizer que a data de pagamento é hoje 


Adicione mais uma Nova Regra e 
depois clique em "Usar uma fórmula para determinar quais células devem ser formatadas"

Na caixa "Edite valores em que esta fórmula é verdadeira" e digite a fórmula que compara a data da planilha com a data de hoje.

Essa fórmula diz o seguinte para o Excel:
=SE(B2

Se a célula B2 tiver uma data menor do que a data de hoje....
Clique no botão Formatar
e
vamos novamente para a Formatação Condicional....

Na Guia Preenchimento, escolha uma cor para o fundo da célula 
Agora foi a cor Vermelha que eu escolhi para dizer que a data de pagamento já passou...

Podemos então visualizar as três regras de Formatação... 

Clicando em Ok, o Excel aplica a Formatação Condicional de acordo com a data das células

Se alterarmos qualquer data para a data de HOJE que é dia 04 de Outubro, automaticamente já formata em cor Laranja.

Gostou? Tem sugestões e opinião diferente? Deixe seu comentário.. Se você gosta de ler e aprender com o Blog da Qualitá, clique em Seguir e receba tudo em primeira mão. Abraços a todos!!
Reações:

0 comentários:

Tecnologia do Blogger.
You can replace this text by going to "Layout" and then "Page Elements" section. Edit " About "

Siga-nos

twitterfacebookgoogle pluslinkedinrss feedemail